[Ipe-discuss] Help! Non-ASCII pathnames under Windows Vista

Günter Rote rote at inf.fu-berlin.de
Tue Nov 10 23:32:51 CET 2009

Is there any fix or workaround for the following problem:

I am one of the unfortunate people having a non-ASCII Character in
my name and in my account name for the PC at home.
Under Windows Vista, the software
behind ipe apparently starts some transliteration process that
translates these characters to characters that the computer
cannot recognize:

When trying to run pdflatex, I get the following message:

C:\Program Files\ipe-7.0.8\bin>cd "C:\Users\G³nter\AppData\Local\ipe\"
Das System kann den angegebenen Pfad nicht finden.
(The system cannot find this path.)

C:\Program Files\ipe-7.0.8\bin>pdflatex text.tex
This is pdfeTeX, Version 3.141592-1.30.6-2.2 (MiKTeX 2.5)
entering extended mode
! I can't find file `text.tex'.
<*> text.tex

Please type another input file name:


(creating a directory C:\Users\G³nter wouldn't work, since
ipe would still write into C:\Users\Günter.)

(Ipe is apparently conscious of these problems, since the ipe
installation instructions say that it should be in a directory
whose path contains neither spaces nor non-ASCII characters.

(Nevertheless, my ipe is installed in "C:\Program Files\ipe-7.0.8".
I have also tried a path without spaces,
so this is definitely not the problem.)

(I had the same problem with running latex from emacs.
Luckily I somehow figured out how to change the small cmdproxy.c stub 
There is apparently some overcompensation of errors:

 >  /* In theory, passing NULL for the environment block to CreateProcess
 >     is the same as passing the value of GetEnvironmentStrings, but
 >     doing this explicitly seems to cure problems running DOS programs
 >     in some cases.  */
 >  /*  char * envblock = GetEnvironmentStrings (); removed G.Rote */
 >  if (CreateProcess (progname, cmdline, &sec_attrs, NULL, TRUE,
 >	             0, envblock, dir, &start, &child))

... replacing envblock by NULL made it work.

On another matter, I have tried to use ipe from a different account
on my computer, and found that I apparently would have
to updated my pdflatex:

This is pdfeTeX, Version 3.141592-1.30.6-2.2 (MiKTeX 2.5)
(preloaded format=pdflatex 2007.6.1)  10 NOV 2009 22:24
entering extended mode
LaTeX2e <2005/12/01>

! Undefined control sequence.
\ipesetcolor ->\pdfcolorstack
                               0 push{0 0 0 0 k 0 0 0 0 K}
l.48 \ipesetcolor
In installed this version in April 2007, and I would rather
avoid having to install a new version. Is there a workaround?
Could I perhaps put a \pdfcolorstack definition in the preamble?
(Is that \pdfcolorstack stuff really necessary?
Otherwise, the required pdflatex version should at least be documented.)

(My computer in the office has a newer version:
This is pdfTeXk, Version 3.141592-1.40.3 (Web2C 7.5.6)
LaTeX2e <2005/12/01>

More information about the Ipe-discuss mailing list