[Ipe-discuss] freetype problem when running pdftex

Rainer Typke rainer.typke at cs.uu.nl
Tue Sep 2 12:27:29 CEST 2003

- freetype:

Okay, that helped. I don't know what I did wrong yesterday, I basically 
did the same thing again (but this time with freetype 2.1.5). I probably 
did not copy all rebuilt ipe libraries and executables into the right 
directories yesterday. Is there also an "install" target? I just 
followed the instructions and copied the stuff by hand.

Thanks for your help! It looks like a very useful program, addressing 
exactly the shortcomings of the otherwise very powerful LaTeX system. 
Too bad Ipe is not more widely known.

- presentation/recurring elements on multiple pages:

 You mention in the documentation that "style sheets can also contain 
... logos to be displayed on each page". The example in the 
documentation does not seem to do that. Do you have an example that 
demonstrates this feature? Can I make any combination of object types 
(text/polygons/bitmaps) reappear on subsequent pages and, if necessary, 
edit only once to update all pages?

Best regards,


Otfried Cheong wrote:

> > Actually, it points to /usr/lib/libfreetype.so.6.3.3, which is the new 
> > one which I compiled this morning.
> > Just to be sure, I removed all old freetype library files, so now there 
> > are only the version 2.1.4 .so and .a file I compiled this morning and 
> > the links to them. Ipe's behaviour when "Latex"ing is still the same.
> > 
> > Is it really clear that version 12.136534824.136454352 is actually 
> > version 2.0.4?
>No :-)  It's what FT_Library_Version returns (the code is in
>Perhaps the linker was still looking at the older version when
>linking?  Have you recompiled Ipe after removing the last traces of
>the old libfreetype?
>I'm pretty sure there is a versioning problem, so if you are sure that
>all files belonging to the old library (include files and
>libfreetype.so) have been removed, recompiling Ipe should work.  To be
>sure, you can go into src/ipe and say "make clean".
>If that still doesn't work, you'll have to start debugging... 

More information about the Ipe-discuss mailing list