[Ipe-discuss] freetype problem when running pdftex

Rainer Typke rainer.typke at cs.uu.nl
Mon Sep 1 17:35:00 CEST 2003

Actually, it points to /usr/lib/libfreetype.so.6.3.3, which is the new 
one which I compiled this morning.
Just to be sure, I removed all old freetype library files, so now there 
are only the version 2.1.4 .so and .a file I compiled this morning and 
the links to them. Ipe's behaviour when "Latex"ing is still the same.

Is it really clear that version 12.136534824.136454352 is actually 
version 2.0.4?

Best regards,


Otfried Cheong wrote:

> >  I compiled Ipe with Freetype 2.1.4. When I run pdftex using the File 
> > menu, I get the message "Ipe has been compiled using the header files of 
> > Freetype version 2.1.4, but is linked with Freetype library version 
> > 12.136534824.136454352. No text display is possible". After clicking on 
> > "Dismiss", Ipe terminates with a segmentation fault.
> > 
> > I compiled and installed Freetype according to the instructions, so I 
> > don't know how Ipe is getting the impression that I am using version 
> > 12.136534824.136454352 instead of 2.1.4.
>Well, presumably the dynamic linker is finding the wrong freetype
>Do "ldd ipe" on the Ipe binary you compiled.  This will probably
>show a pointer to /usr/lib/libfreetype.so.X.X, which is your system
>freetype library, version 2.0.4.  What it should find is the new
>freetype library...

More information about the Ipe-discuss mailing list