[Ipe-discuss] Can't run Ipe 7.2.7 AppImage with fontconfig 2.13.0

Mathias Rav m at git.strova.dk
Fri May 11 10:14:11 CEST 2018

When I run ipe-7.2.7-x86_64.AppImage I get the error:

ipe: symbol lookup error: /usr/lib/libfontconfig.so.1: undefined symbol: FT_Done_MM_Var

I upgraded fontconfig 2.12.6+5+g665584a-1 -> 2.13.0+10+g58f5285-1
on 2018-04-02. Today when I wanted to start Ipe I got the message above.

After a bit of research [1] [2] it looks like other people get the same
error with other programs/AppImages that bundle libfreetype or libz.

[1] https://bugs.archlinux.org/task/57948
[2] https://gist.github.com/nemanjan00/dca98f1

Does Ipe bundle either of those libraries in its AppImage? Based on [2]
I tried to run the Ipe AppImage with --appimage-extract but that flag is
not recognized. Is there a good way of debugging AppImage startup

I'll compile Ipe from source for now, but I'd rather use the AppImage
if possible.

Best regards,
Mathias Rav

More information about the Ipe-discuss mailing list