[Ipe-discuss] how to: different fonts in the same file

Carsten Weise realtimecarsten at gmail.com
Sun Dec 21 15:10:23 CET 2014

Time passes so fast before Christmas...
Only today I found some time to look into this again.
Turns out your fix works in my setup as well.


On Mon, Dec 1, 2014 at 12:59 AM, Otfried Cheong <otfried at ipe.airpost.net>

> On 01/12/14 06:46, Carsten Weise wrote:
> > Hej Michael,
> >
> > ok so this is good news.
> > However, I have the same problem when I follow your approach - si it
> > must be in my configuration.
> >
> > I'm running ipe V 7.1.4, pdflatex says "pdfTeX 3.1415926-2.5-1.40.14",
> > and I'm on Ubuntu 14.4.
> >
> > Is there a way to see the pdflatex output from ipe?
> In Ipe, go to Help->Show configuration and look for the Latex directory.
>   On Linux, this would normally be $HOME/.ipe/latexrun.
> cd to this directory.  The Latex source created by Ipe is in
> ipetemp.pdf, the log file in ipetemp.log, the created PDF in ipetemp.pdf.
> You should also run "pdflatex ipetemp.tex" manually in this directory
> and see what happens.  When Ipe complains that "An error occurred during
> the Pdflatex run", it usually means that you are using fonts that are
> not in Postscript Type 1 or TTF format.
> I installed texlive-fonts-extra and tried your example. My ipetemp.log
> contains this:
> LaTeX Font Info:    Try loading font information for T1+libertine on
> input line
>   53.
> LaTeX Font Info:    No file T1libertine.fd. on input line 53.
> LaTeX Font Warning: Font shape `T1/libertine/m/n' undefined
> (Font)              using `T1/cmr/m/n' instead on input line 53.
> If I then open ipetemp.pdf in evince and look at the Fonts in document
> properties, it shows a Type 3 font (CMR, created by Metafont).  Ipe does
> not handle Type 3 fonts, because they are bitmap fonts and do not scale
> - so that explains the error message.
> So I went back to your short Latex test tile.  While it runs through
> pdflatex and produces a PDF file with two different fonts, it actually
> has the same problem.  The second font is not Libertine, but CMR in a
> bitmap font (look at font properties in evince again)!
> However, uncommenting \usepackage{dejavu} and the selectfont command
> shows that Libertine actually works in Latex, so the problem must be the
> \fontfamily setting.
> A quick look at libertine.sty shows that this is indeed the case:  The
> name of the font family is not "libertine", but something much more
> complicated.  I changed the text object to read like this:
> ===
> This is a very simple document. The first paragraph should use dejavu as
> font.
> {\fontencoding{T1}
> \makeatletter\fontfamily{\libertine at family}\makeatother
> \selectfont
> OK, we fill this with a little more content. So this is the second
> paragraph in this document. This should be in libertine.
> }
> ===
> and now it works.
> The interesting question is - what is different in Michael's setup?
> Cheers,
>   Otfried
> _______________________________________________
> Ipe-discuss mailing list
> Ipe-discuss at lists.science.uu.nl
> http://lists.science.uu.nl/mailman/listinfo/ipe-discuss
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.science.uu.nl/pipermail/ipe-discuss/attachments/20141221/f3a12feb/attachment.html 

More information about the Ipe-discuss mailing list