[Ipe-discuss] Ipe 7 and Mac OS 10.6

Marc Scherfenberg marcscherfenberg at arcor.de
Wed Nov 11 16:45:38 CET 2009

This is strange, now ipe compiles with lua installed by MacPorts with just a simple modification in config.mak, which I also tried before:

it works using
LUA_CFLAGS    ?= $(shell pkg-config --cflags lua)
LUA_LIBS      ?= $(shell pkg-config --libs lua)

instead of
LUA_CFLAGS    ?= $(shell pkg-config --cflags lua5.1)
LUA_LIBS      ?= $(shell pkg-config --libs lua5.1)

If lua is installed manually from the source code, the file lua.pc cannot be find by pkg-config, although it is among the source files. Thus LUA_CFLAGS and LUA_LIBS or the lua.pc file needs to be configured manually then.  

The difference in the directory structure is actually quite simple. There is an additional .../share/lua/5.1 and .../lib/lua/5.1 directory in the manual installation, where ... stands for the prefix /usr/local. But I don't think anymore that it causes problems. Probably there was some interference with other issues. 


Am 11.11.2009 um 15:47 schrieb Otfried Cheong:

> Marc Scherfenberg wrote:
>> It seems there are some modifications necessary in order to get Ipe 7 compiled on the current Mac OS 10.6. 
>> So maybe there are some people interested in how it worked for me.
> Thanks!
>> - lua: compiled source manually, as the MacPorts directory structure of lua is different from what ipe expects. Add  '-arch x86_64' to the CFLAGS in the makefile.
> Can you explain what is different?  It should be easy to fix this (Ipe
> simply links against liblua).
> Otfried

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3691 bytes
Desc: not available
Url : http://lists.science.uu.nl/pipermail/ipe-discuss/attachments/20091111/dca98446/attachment.bin 

More information about the Ipe-discuss mailing list